rtklib: move to github
[packages.git] / utils / devio / Makefile
index ecac1c5..f632c62 100644 (file)
@@ -1,10 +1,9 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,31 +15,19 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/devio
 PKG_MD5SUM:=5d332c2bffc0791367bcf3368ba1a0d1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/devio
+  SUBMENU:=disc
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=Correctly write to and read from mtd character (and other block) devices
-  DESCRIPTION:=\
-       A command line program to correctly read (or write) a region of a block device.\\\
-       Primary use is for extracting formatted data from MTD partitions.
+  TITLE:=correctly read (or write) a region of a block device
   URL:=http://sourceforge.net/projects/devio/
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR) ; \
-               ./configure \
-       );
-endef
-
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="$(EXTRA_CFLAGS)" \
-               LDFLAGS="$(EXTRA_LDFLAGS)" \
-       )
+define Package/devio/description
+       A command line program to correctly read (or write) a region of a block device.
+       Primary use is for extracting formatted data from MTD partitions.
 endef
 
 define Package/devio/install