zip: move to github
[packages.git] / utils / avrusbboot / Makefile
index 546949e..81063b0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avrusbboot
 PKG_VERSION:=2006-06-25
-PKG_RELEASE:=1
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.fischl.de/avrusbboot/
@@ -17,12 +17,13 @@ PKG_MD5SUM:=3e2f5e2c257918410a66c3463f583fdf
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
 
+include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/avrusbboot
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libusb +uclibcxx +libgcc
+  DEPENDS:=+libusb-compat $(CXX_DEPENDS)
   TITLE:=USB bootloader for Atmel AVR controllers
   URL:=http://www.fischl.de/avrusbboot/
 endef
@@ -40,8 +41,9 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/software \
-               CXX="$(TARGET_CROSS)g++ $(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++ $(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++" \
-               LFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++ -lc -lusb $(LIBGCC_S)" \
+               CXX="$(TARGET_CXX)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -fno-rtti" \
+               LFLAGS="$(TARGET_LDFLAGS) $(TARGET_CFLAGS) -lusb" \
                all
 endef