cmus: fix configure checks against host files
[packages.git] / sound / madplay / Makefile
index 379e22c..bf0b93c 100644 (file)
@@ -1,25 +1,23 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=madplay
 PKG_VERSION:=0.15.2b
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mad \
        ftp://ftp.mars.org/pub/mpeg/
 PKG_MD5SUM:=6814b47ceaa99880c754c5195aa1aac1
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,14 +26,16 @@ define Package/madplay
   CATEGORY:=Sound
   DEPENDS:=+libid3tag +libmad
   TITLE:=MPEG audio player in fixed point
-  DESCRIPTION:=\
-       MAD is an MPEG audio decoder. It currently only supports the MPEG 1 \\\
-       standard, but fully implements all three audio layers (Layer I, Layer II, \\\
-       and Layer III, the latter often colloquially known as MP3.).  There is also \\\
-       full support for ID3 tags.
   URL:=http://sourceforge.net/projects/mad
 endef
 
+define Package/madplay/description
+       MAD is an MPEG audio decoder. It currently only supports the MPEG 1 
+       standard, but fully implements all three audio layers (Layer I, Layer II, 
+       and Layer III, the latter often colloquially known as MP3.). There is also 
+       full support for ID3 tags.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -52,15 +52,9 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/madplay/install 
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
+define Package/madplay/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,madplay))