[dnsmasq] Update to version 2.52
[10.03/openwrt.git] / package / dnsmasq / Makefile
index 3599fa0..d3399ab 100644 (file)
@@ -1,20 +1,19 @@
 # 
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.47
-PKG_RELEASE:=2
+PKG_VERSION:=2.52
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=4524081e56d0b935717d493e8e8d3e11
+PKG_MD5SUM:=1bb32fffdb4f977ead607802b5d701d0
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,6 +30,7 @@ endef
 
 define Package/dnsmasq/conffiles
 /etc/config/dhcp
+/etc/dnsmasq.conf
 endef
 
 define Build/Compile
@@ -47,6 +47,7 @@ define Package/dnsmasq/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
 endef