tar: moved to github
[packages.git] / net / xsupplicant / Makefile
index ec56621..64ee2c5 100644 (file)
@@ -16,19 +16,22 @@ PKG_SOURCE_URL:=@SF/open1x
 PKG_MD5SUM:=75f89731b905eb8d36a52621661e1226
 
 PKG_BUILD_DEPENDS:=PACKAGE_kmod-madwifi:madwifi
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=0
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/xsupplicant
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=wireless
   DEPENDS:=+libopenssl +libiw
   TITLE:=A fully compliant 802.1x authenticator
   URL:=http://open1x.sourceforge.net/
 endef
 
 define Package/xsupplicant/description
- This software allows a GNU/Linux or BSD workstation to authenticate with 
+ This software allows a GNU/Linux or BSD workstation to authenticate with
  a RADIUS server using 802.1x and various EAP protocols.
 endef
 
@@ -55,13 +58,7 @@ define Build/Prepare
        );
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/xsupplicant/install     
+define Package/xsupplicant/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/xsupplicant.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/bin