DESCRIPTION:= is obselete
[packages.git] / net / xsupplicant / Makefile
index c0b980e..3af26d2 100644 (file)
@@ -9,17 +9,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xsupplicant
-PKG_VERSION:=1.2.7
+PKG_VERSION:=1.2.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/open1x
-PKG_MD5SUM:=f66c49cd6e4f331d05bf83513ed91990
+PKG_MD5SUM:=75f89731b905eb8d36a52621661e1226
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
+PKG_BUILD_DEPENDS:=madwifi
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/xsupplicant
@@ -27,12 +29,14 @@ define Package/xsupplicant
   CATEGORY:=Network
   DEPENDS:=+libopenssl +wireless-tools
   TITLE:=A fully compliant 802.1x authenticator
-  DESCRIPTION:=\
-       This software allows a GNU/Linux or BSD workstation to authenticate with \\\
-       a RADIUS server using 802.1x and various EAP protocols.
   URL:=http://open1x.sourceforge.net/
 endef
 
+define Package/xsupplicant/description
+       This software allows a GNU/Linux or BSD workstation to authenticate with 
+       a RADIUS server using 802.1x and various EAP protocols.
+endef
+
 define Package/xsupplicant/conffiles
 /etc/xsupplicant.conf
 endef
@@ -54,16 +58,16 @@ endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR=$(PKG_INSTALL_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/xsupplicant/install     
-       install -d -m0755 $(1)/etc
-       install -m0644 $(PKG_BUILD_DIR)/etc/xsupplicant.conf $(1)/etc/
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/xsupplicant.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/xsup_* $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/xsupplicant $(1)/usr/sbin/
 endef