tinc: moved to github
[packages.git] / net / wiviz / Makefile
index ff7cc5f..053517f 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -12,16 +11,15 @@ PKG_NAME:=wiviz
 PKG_VERSION:=1.0
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/wiviz
   SECTION:=net
   CATEGORY:=Network
+  SUMENU:=wireless
   DEPENDS:=+libpcap
   TITLE:=Wireless Network Visualization
-  URL:=http://students.washington.edu/natetrue/wiviz/
+  URL:=http://devices.natetrue.com/wiviz/
 endef
        
 define Build/Prepare
@@ -29,16 +27,19 @@ define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
+EXTRA_LDFLAGS += $(TARGET_LDFLAGS)
+
 define Build/Compile
        $(call Build/Compile/Default, \
-               CCOPTS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
-               INCLUDE="" \
+               CCOPTS="$(TARGET_CFLAGS)" \
+               INCLUDE="$(EXTRA_CFLAGS)" \
                LDFLAGS="$(EXTRA_LDFLAGS)" \
        )
 endef
 
 define Package/wiviz/install   
-       mkdir -p $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
        $(CP) ./files/* $(1)
        find $(1) -name CVS | xargs rm -rf