nmap: moved to github
[packages.git] / net / vpnc / Makefile
index 7976d91..58af207 100644 (file)
@@ -1,55 +1,61 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vpnc
-PKG_VERSION:=0.3.3
-PKG_RELEASE:=1
-
-PKG_MD5SUM:=e7518cff21326fe7eb9795b60c25ae6a
-PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
+PKG_VERSION:=0.5.3
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
+PKG_MD5SUM:=4378f9551d5b077e1770bbe09995afb3
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vpnc
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libgpg-error +libgcrypt +kmod-tun
-  TITLE:=VPN client for Cisco 3000
-  DESCRIPTION:=Client for cisco3000 VPN Concentrator
+  DEPENDS:=+libgpg-error +libgcrypt +kmod-tun +vpnc-scripts
+  TITLE:=VPN client for Cisco EasyVPN
   URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
+  SUBMENU:=VPN
+endef
+
+define Package/vpnc/description
+       A VPN client compatible with Cisco's EasyVPN equipment.
+
+       Supports IPSec (ESP) with Mode Configuration and Xauth.  Supports only
+       shared-secret IPSec authentication with Xauth, AES (256, 192, 128),
+       3DES, 1DES, MD5, SHA1, DH1/2/5 and IP tunneling.
 endef
 
 define Package/vpnc/conffiles
-/etc/vpnc/vpnc.conf
-/etc/vpnc/vpnc-script
+/etc/vpnc/default.conf
 endef
 
 define Build/Compile
-$(call Build/Compile/Default,CC="$(TARGET_CC)" \
+       $(call Build/Compile/Default, \
                OFLAGS="$(TARGET_CFLAGS)" \
                OS="Linux" \
                STAGING_DIR="$(STAGING_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                PREFIX=/usr \
-               all install)
+               all install \
+       )
 endef
 
 define Package/vpnc/install
-       install -d -m0755 $(1)
-       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP)   $(PKG_INSTALL_DIR)/usr/sbin/vpnc \
+               $(PKG_INSTALL_DIR)/usr/sbin/vpnc-disconnect \
+               $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/vpnc
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/vpnc/default.conf $(1)/etc/vpnc/
 endef
 
 $(eval $(call BuildPackage,vpnc))