uob-nomad: Internal dependencies are broken. Force -j1 for now.
[packages.git] / net / uob-nomad / Makefile
index 40104d8..b630bb7 100644 (file)
@@ -3,7 +3,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -14,10 +13,9 @@ PKG_MD5SUM:=9c7445cefaf8d6160017aef606f2e558
 
 PKG_SOURCE_URL:=http://www.comnets.uni-bremen.de/~mab/openwrt/source/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+# Force -j1
+PKG_JOBS:=
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,17 +24,20 @@ define Package/uob-nomad
   CATEGORY:=Network
   DEPENDS:=+kmod-iptunnel4 +libpthread
   TITLE:=UoB Nomad
-  DESCRIPTION:=This is an implementation of NOMADv4 (Filters for\\\
-       Mobile IP, IETF Draft\\\
-       draft-mobileip-nomad-filters-05.txt) for Linux,\\\
-       based on the Sun Labs Mobile IP software. It is\\\
-       released under the Sun Public License (SPL).\\\
-       \\\
-       This version (0.11) has been modified to provide\\\
-       status information to the UoB-NOMAD-GUI (ver 0.1).
   URL:=http://www.comnets.uni-bremen.de/~mab/openwrt/source/
 endef
 
+define Package/uob-nomad/description
+This is an implementation of NOMADv4 (Filters for
+       Mobile IP, IETF Draft
+       draft-mobileip-nomad-filters-05.txt) for Linux,
+       based on the Sun Labs Mobile IP software. It is
+       released under the Sun Public License (SPL).
+       
+       This version (0.11) has been modified to provide
+       status information to the UoB-NOMAD-GUI (ver 0.1).
+endef
+
 define Build/Compile
 $(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Agent mipagent)
 $(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client/net-tools clean)