squid: moved to github
[packages.git] / net / unfs3 / Makefile
index b5ab89d..339b3cf 100644 (file)
@@ -1,27 +1,32 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unfs3
-PKG_VERSION:=0.9.20
-PKG_RELEASE:=1
+PKG_VERSION:=0.9.22
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=2920d9cc7c3cb76da0792669bf035650
+PKG_MD5SUM:=ddf679a5d4d80096a59f3affc64f16e5
+
+PKG_LICENSE:=UNFS3
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_PARALLEL:=0
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/unfs3
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+portmap
+  SUBMENU:=Filesystem
+  DEPENDS:=+portmap $(LIBRPC_DEPENDS)
   TITLE:=User-space NFSv3 Server
   URL:=http://unfs3.sourceforge.net/
 endef
@@ -33,6 +38,9 @@ define Package/unfs3/description
        on the server.
 endef
 
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+TARGET_LDFLAGS += $(LIBRPC)
+
 define Package/unfs3/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
@@ -42,4 +50,8 @@ define Package/unfs3/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unfsd $(1)/usr/sbin
 endef
 
+define Package/unfs3/conffiles
+/etc/exports
+endef
+
 $(eval $(call BuildPackage,unfs3))