packages/transmission: use new service functions, rename 'run_daemon_as_user' config...
[packages.git] / net / transmission / Makefile
index 679a7e3..3dd8df1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
-PKG_VERSION:=2.22
+PKG_VERSION:=2.42
 PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
-PKG_MD5SUM:=6499986bf769276310b00bda1090090d
+PKG_MD5SUM:=2ade0818d465779bd956b8b72ea56b02
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -32,7 +32,7 @@ endef
 
 define Package/transmission-daemon
   $(call Package/transmission/template)
-  DEPENDS:=+libcurl +libopenssl +libpthread +libevent2
+  DEPENDS:=+libcurl +libopenssl +libpthread +libevent2 +librt
   MENU:=1
 endef