DESCRIPTION:= is obselete
[packages.git] / net / ssmtp / Makefile
index 079a4cf..3bacab5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,9 +15,6 @@ PKG_RELEASE:=2
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/s/ssmtp/
 PKG_MD5SUM:=957e6fff08625fe34f4fc33d0925bbc9
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,30 +23,25 @@ define Package/ssmtp
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=A minimal and secure mail sender
-  DESCRIPTION:=\
-       A secure, effective and simple way of getting mail off a system to your \\\
-       mail hub. It contains no suid-binaries or other dangerous things - no \\\
-       mail spool to poke around in, and no daemons running in the background.\\\
-       mail is simply forwarded to the configured mailhost. Extremely easy \\\
-       configuration.
   URL:=http://packages.debian.org/stable/mail/ssmtp
 endef
 
-# uses GNU configure
-
-define Build/Configure
-       cd $(PKG_BUILD_DIR)
-       $(call Build/Configure/Default, \
-               --enable-ssl \
-       )
+define Package/ssmtp/description
+       A secure, effective and simple way of getting mail off a system to your 
+       mail hub. It contains no suid-binaries or other dangerous things - no 
+       mail spool to poke around in, and no daemons running in the background.
+       mail is simply forwarded to the configured mailhost. Extremely easy 
+       configuration.
 endef
 
-define Build/Compile
-       EXTRA_CFLAGS="-I$(STAGING_DIR)/usr/include" \
-       EXTRA_LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               all
-endef
+EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
+
+TARGET_CONFIGURE_OPTS+=\
+       CC="$(TARGET_CC) $(EXTRA_CFLAGS) $(EXTRA_LDFLAGS)"
+
+CONFIGURE_ARGS += \
+       --enable-ssl
 
 define Package/ssmtp/install   
        $(INSTALL_DIR) $(1)/etc/ssmtp