[packages] Use default templates instead of custom reimplementations where applicable
[packages.git] / net / slurm / Makefile
index cc6589e..53096f0 100644 (file)
@@ -12,9 +12,11 @@ PKG_VERSION:=0.3.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.wormulon.net/files/code/slurm/
+PKG_SOURCE_URL:=http://www.wormulon.net/slurm/
 PKG_MD5SUM:=e68d09202b835c644f7f6b7f070f29a2
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/slurm
@@ -22,7 +24,7 @@ define Package/slurm
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A realtime network interface monitor
-  URL:=http://www.wormulon.net/projects/slurm
+  URL:=http://www.wormulon.net/slurm/
 endef
 
 define Package/slurm/description
@@ -34,7 +36,7 @@ define Package/slurm/description
        - it's themeable.
 endef
 
-define Build/Configure 
+define Build/Configure
        (cd $(PKG_BUILD_DIR); touch \
                configure.in \
                aclocal.m4 \
@@ -49,13 +51,7 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/slurm/install   
+define Package/slurm/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
 endef