tinc: moved to github
[packages.git] / net / rssh / Makefile
index 31401fb..8e7e9f1 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rssh
-PKG_VERSION:=2.3.2
+PKG_VERSION:=2.3.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/rssh
-PKG_MD5SUM:=65712f2c06ff5fc6fc783bc8c2e4e1ba
+PKG_MD5SUM:=b0c147602fcc95737ed50573b92fc468
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/rssh
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=SSH
   TITLE:=restricted shell for use with OpenSSH
   URL:=http://www.pizzashack.org/rssh/index.shtml
 endef
@@ -35,28 +38,25 @@ define Package/rssh/conffiles
 /etc/rssh.conf
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default,\
-               --with-sftp-server="/usr/libexec/sftp-server" \
-               ,\
-               ac_cv_func_malloc_0_nonnull=yes \
-       )
-endef
+CONFIGURE_ARGS += \
+       --with-sftp-server="/usr/libexec/sftp-server" \
 
-define Build/Compile
-       $(call Build/Compile/Default,\
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all \
-       )
-endef
+CONFIGURE_VARS += \
+       ac_cv_func_malloc_0_nonnull=yes \
 
 define Package/rssh/install
-       $(INSTALL_DIR) $(1)/etc/
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin
-       $(INSTALL_DIR) $(1)/usr/lib/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/rssh_chroot_helper $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/$(PKG_NAME).conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/rssh_chroot_helper $(1)/usr/lib/
+endef
+
+define Package/rssh/postinst
+#!/bin/sh
+grep rssh $${IPKG_INSTROOT}/etc/shells || \
+       echo "/usr/bin/rssh" >> $${IPKG_INSTROOT}/etc/shells
 endef
 
 $(eval $(call BuildPackage,rssh))