nfs-kernel-server: moved to github
[packages.git] / net / rarpd / Makefile
index 5416423..25a98a8 100644 (file)
@@ -1,26 +1,28 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rarpd
 PKG_VERSION:=1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.dementia.org/pub/net-tools
 PKG_MD5SUM:=04e2ca849e758d0b88c8281775ec3b58
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/rarpd
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=IP Addresses and Names
   DEPENDS:=+libnet0
   TITLE:=Reverse ARP Daemon
   URL:=ftp://ftp.dementia.org/pub/net-tools/
@@ -34,28 +36,24 @@ define Package/rarpd/description
        database.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.0.x" \
-               --with-pcap="$(STAGING_DIR)/usr" \
-               , \
-               CFLAGS="$$$$CFLAGS -DNEW_LIBNET_INTERFACE" \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.0.x" \
+       --with-pcap="$(STAGING_DIR)/usr" \
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_VARS+= \
+       CFLAGS="$$$$CFLAGS -DNEW_LIBNET_INTERFACE" \
 
-define Package/rarpd/install   
+define Package/rarpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/rarpd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/default
-       install -m644 ./files/rarpd.default $(1)/etc/default/rarpd
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/rarpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/rarpd.config $(1)/etc/config/rarpd
        $(INSTALL_DIR) $(1)/etc/init.d
-       install -m755 ./files/rarpd.init $(1)/etc/init.d/rarpd
+       $(INSTALL_BIN) ./files/rarpd.init $(1)/etc/init.d/rarpd
+endef
+
+define Package/rarpd/conffiles
+/etc/config/rarpd
 endef
 
 $(eval $(call BuildPackage,rarpd))