horst: moved to github
[packages.git] / net / qolyester / Makefile
index 86cc568..3b7f25f 100644 (file)
@@ -1,29 +1,28 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qolyester
-PKG_VERSION:=20070910
+PKG_VERSION:=20090302
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
-PKG_MD5SUM:=9c1cf1868e085f47e135a86945d93ce0
+PKG_SOURCE_URL:=http://qolsr.lri.fr/code/
+PKG_MD5SUM:=650286fc2ea3e13c246d233aaa46f2a4
 
-PKG_BUILD_DEPENDS:=libnotimpl
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/qolyester
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpthread
+  DEPENDS:=+libpthread +libstdcpp @!TARGET_avr32 @!powerpc
   TITLE:=OLSR implementation with QoS
   URL:=http://qolsr.lri.fr/code/
 endef
@@ -35,14 +34,8 @@ define Package/qolyester/description
 endef
 
 # uses GNU configure
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               LIBS="-L$(STAGING_DIR)/usr/lib -lnotimpl" \
-               all install
-endef
 
-define Package/qolyester/install       
+define Package/qolyester/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/qolsrd $(1)/usr/bin/
 endef