DESCRIPTION:= is obselete
[packages.git] / net / psybnc / Makefile
index 3c35a50..d4ca773 100644 (file)
@@ -22,19 +22,22 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 include $(INCLUDE_DIR)/package.mk
 
 define Package/psybnc
+  SUBMENU:=Instant Messaging
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=
   TITLE:=An IRC-Bouncer with many features
-  DESCRIPTION:=\
-       psyBNC is an easy-to-use, multi-user, permanent \\\
-       IRC-Bouncer with many features. Some of its features \\\
-       vhost- and relay support to connected bouncers and an \\\
-       extensive online help system. Many other helpful \\\
-       functions are included.
   URL:=http://www.psybnc.info/
 endef
 
+define Package/psybnc/description
+       psyBNC is an easy-to-use, multi-user, permanent 
+       IRC-Bouncer with many features. Some of its features 
+       vhost- and relay support to connected bouncers and an 
+       extensive online help system. Many other helpful 
+       functions are included.
+endef
+
 define Build/Compile   
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -48,7 +51,7 @@ define Package/psybnc/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/psybnc.sh $(1)/usr/sbin/psybnc
        $(INSTALL_DIR) $(1)/usr/share/psybnc
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/psybnc $(1)/usr/share/psybnc/
-       install -m0600 $(PKG_BUILD_DIR)/psybnc.conf $(1)/usr/share/psybnc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/psybnc.conf $(1)/usr/share/psybnc/
        $(INSTALL_DIR) $(1)/usr/share/psybnc/lang
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/lang/english.lng $(1)/usr/share/psybnc/lang/
 endef