cups: configure: disable acl
[packages.git] / net / proftpd / Makefile
index 554608e..dff7233 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,24 +8,25 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=proftpd
-PKG_VERSION:=1.3.2e
+PKG_VERSION:=1.3.5
 PKG_RELEASE:=1
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.proftpd.org/distrib/source
-PKG_MD5SUM:=018e0eb1757d9cea2a0e17f2c9b1ca2d
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=aff1bff40e675244d72c4667f203e5bb
 
-PKG_FIXUP:=libtool
-PKG_INSTALL=1
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/proftpd
-  SUBMENU:=FTP
+  SUBMENU:=File Transfer
   SECTION:=net
   CATEGORY:=Network
   TITLE:=ProFTPD FTP server
   URL:=http://www.proftpd.org/
+  MAINTAINER:=Cezary Jackiewicz <cezary@eko.one.pl>
 endef
 
 define Package/proftpd/conffiles
@@ -42,10 +43,16 @@ MAKE_FLAGS += \
 CONFIGURE_ARGS += \
        --disable-cap \
        --enable-devel \
+       --disable-auth-pam \
+       ac_cv_header_curses_h=no \
+       ac_cv_header_ncurses_h=no
 
 define Package/proftpd/install
        $(INSTALL_DIR) $(1)/etc
+       $(if $(CONFIG_IPV6),,$(SED) 's/^UseIPv6/#UseIPv6/' $(PKG_INSTALL_DIR)/etc/proftpd.conf)
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/proftpd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/proftpd.init $(1)/etc/init.d/proftpd
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ftp{count,top,who} $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin