prosody: moved to github
[packages.git] / net / proftpd / Makefile
index 080974d..dff7233 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=proftpd
-PKG_VERSION:=1.3.4a
+PKG_VERSION:=1.3.5
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.proftpd.org/distrib/source
-PKG_MD5SUM:=4e3235dc1ef95d36e59721d70c5c489c
+PKG_MD5SUM:=aff1bff40e675244d72c4667f203e5bb
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -42,7 +42,10 @@ MAKE_FLAGS += \
 
 CONFIGURE_ARGS += \
        --disable-cap \
-       --enable-devel
+       --enable-devel \
+       --disable-auth-pam \
+       ac_cv_header_curses_h=no \
+       ac_cv_header_ncurses_h=no
 
 define Package/proftpd/install
        $(INSTALL_DIR) $(1)/etc