redsocks: moved to github
[packages.git] / net / mutella / Makefile
index 76e5b33..d7a3502 100644 (file)
@@ -1,21 +1,23 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mutella
 PKG_VERSION:=0.4.5
-PKG_RELEASE:=1
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_MD5SUM:=1a676eacf562e3b8de90493f99fe059c
 
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mutella
@@ -24,7 +26,7 @@ define Package/mutella
   CATEGORY:=Network
   TITLE:=Gnutella client with command line and http interface
   URL:=http://mutella.sourceforge.net/
-  DEPENDS:=+libncurses +libreadline +libpthread +uclibcxx +zlib
+  DEPENDS:=+libncurses +libreadline +libpthread +libstdcpp +zlib
 endef
 
 define Package/mutella/description
@@ -39,26 +41,8 @@ define Package/mutella/description
 endef
 
 CONFIGURE_VARS += \
-       CXX="g++-uc+std" \
        CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
 
-define Build/Prepare
-       $(call Build/Prepare/Default)
-       $(SED) 's,-I$$$$(includedir),,g' $(PKG_BUILD_DIR)/{mutella,util}/Makefile.in
-       $(SED) 's,-L$$$$(libdir),,g' $(PKG_BUILD_DIR)/{mutella,util}/Makefile.in
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default)
-       $(call libtool_disable_rpath)
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
-endef
-
 define Package/mutella/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mutella{,_sio} $(1)/usr/bin/