DESCRIPTION:= is obselete
[packages.git] / net / mini_sendmail / Makefile
index 5ad7d4c..d243d82 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mini-sendmail
-PKG_VERSION:=1.3.5
-PKG_RELEASE:=1
+PKG_VERSION:=1.3.6
+PKG_RELEASE:=2
 
 PKG_SOURCE:=mini_sendmail-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.acme.com/software/mini_sendmail/
-PKG_MD5SUM:=fff344184e98cff0ea4d817da9d29383
-PKG_CAT:=zcat
+PKG_MD5SUM:=fb1585d2ad81c519a26d83bfd783dee8
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/mini_sendmail-$(PKG_VERSION)
 
@@ -25,21 +24,19 @@ define Package/mini-sendmail
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A small sendmail-compatible mail forwarder
-  DESCRIPTION:=\
-       mini_sendmail reads its standard input up to an end-of-file and sends a \\\
-       copy of the message found there to all of the addresses listed.\\\
-       The message is sent by connecting to a local SMTP server. This means \\\
-       mini_sendmail can be used to send email from inside a chroot(2) area.
   URL:=http://www.acme.com/software/mini_sendmail/
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               OFLAGS="$(TARGET_CFLAGS)" \
-               all
+define Package/mini-sendmail/description
+       mini_sendmail reads its standard input up to an end-of-file and sends a 
+       copy of the message found there to all of the addresses listed.
+       The message is sent by connecting to a local SMTP server. This means 
+       mini_sendmail can be used to send email from inside a chroot(2) area.
 endef
 
+MAKE_FLAGS += \
+       OFLAGS="$(TARGET_CFLAGS)"
+
 define Package/mini-sendmail/install   
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/mini_sendmail $(1)/usr/sbin/