nmap: moved to github
[packages.git] / net / keepalived / Makefile
index bcf312b..3a0e430 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=keepalived
-PKG_VERSION:=1.1.15
-PKG_RELEASE:=1
+PKG_VERSION:=1.1.19
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= http://www.keepalived.org/software
-PKG_MD5SUM:=4c93f5d8b6bfabe84b02828a5bbb7aa0
+PKG_MD5SUM:=a35b8d9d462810f7650d292bd7457523
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -23,7 +23,6 @@ define Package/keepalived
   CATEGORY:=Network
   TITLE:=Failover and monitoring daemon for LVS clusters
   URL:=http://www.keepalived.org/
-  SUBMENU:=HA
   DEPENDS:=+libpopt +libopenssl
 endef
 
@@ -32,7 +31,7 @@ define Package/keepalived/description
 endef
 
 define Package/keepalived/conffiles
- /etc/keepalived/keepalived.conf
+/etc/keepalived/keepalived.conf
 endef
 
 acvar=$(subst -,_,$(subst .,_,$(subst /,_,$(1))))
@@ -44,15 +43,9 @@ CONFIGURE_ARGS+= \
        --disable-strip \
        --disable-lvs \
        --disable-lvs-syncd \
-       --with-kernel-dir="$(LINUX_DIR)" \
-
-CONFIGURE_VARS+= \
-       ac_cv_file_$(call acvar,$(LINUX_DIR)/net/core/link_watch.c)=yes \
-       VRRP_SUPPORT=yes \
+       --with-kernel-dir="$(LINUX_DIR)/$(LINUX_UAPI_DIR)"
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                STRIP="/bin/true" \
@@ -61,11 +54,11 @@ endef
 
 define Package/keepalived/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/keepalived $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/keepalived $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/genhash $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/genhash $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc/keepalived
-       $(CP) $(PKG_INSTALL_DIR)/etc/keepalived/keepalived.conf $(1)/etc/keepalived/keepalived.conf
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/keepalived/keepalived.conf $(1)/etc/keepalived/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/keepalived.init $(1)/etc/init.d/keepalived
 endef