socat: moved to github
[packages.git] / net / iptables-snmp / Makefile
index 3ba9729..3e48bc1 100644 (file)
@@ -20,26 +20,27 @@ include $(INCLUDE_DIR)/package.mk
 define Package/iptables-snmp
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+snmpd
+  DEPENDS:=+snmpd +libiptc
   TITLE:=An snmpd plugin to access iptables rules
   URL:=http://www.nobiscuit.com/iptables-snmp/
-  SUBMENU:=firewall
+  SUBMENU:=Firewall
 endef
 
 define Package/iptables-snmp/description
        This is a plugin that makes iptables rules accessable from snmpd.
 endef
 
-define Build/Compile   
+define Build/Compile
        $(call Build/Compile/Default, \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                all install \
        )
 endef
-define Package/iptables-snmp/install   
+
+define Package/iptables-snmp/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/iptables-snmp.so $(1)/usr/lib
-endef 
+endef
 
 $(eval $(call BuildPackage,iptables-snmp))