[packages] ez-ipupdate: fix for zoneedit, rebase patches - didn't apply cleanly anymo...
[packages.git] / net / ez-ipupdate / Makefile
index 2df2636..2188599 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +10,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ez-ipupdate
 PKG_VERSION:=3.0.11b8
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/ez-ipupdate \
        http://ftp.de.debian.org/debian/pool/main/e/ez-ipupdate
 PKG_MD5SUM:=000211add4c4845ffa4211841bff4fb0
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -29,10 +28,6 @@ define Package/ez-ipupdate
   URL:=http://ez-ipupdate.com/
 endef
 
-define Package/ez-ipupdate/conffiles
-/etc/ez-ipupdate.conf
-endef
-
 # uses GNU configure
 
 define Build/Compile
@@ -40,12 +35,12 @@ define Build/Compile
 endef
 
 define Package/ez-ipupdate/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/ez-ipupdate $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc
-       install -m0600 ./files/ez-ipupdate.conf $(1)/etc/
-       install -d -m0755 $(1)/etc/hotplug.d/iface
-       install -m0755 ./files/ez-ipupdate.hotplug $(1)/etc/hotplug.d/iface/10-ez-ipupdate
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ez-ipupdate $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config/
+       $(INSTALL_CONF) ./files/ez-ipupdate.config $(1)/etc/config/ddns
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_BIN) ./files/ez-ipupdate.hotplug $(1)/etc/hotplug.d/iface/30-ez-ipupdate
 endef
 
 $(eval $(call BuildPackage,ez-ipupdate))