nfs-kernel-server: moved to github
[packages.git] / net / axel / Makefile
index 246a12f..415dc7e 100644 (file)
@@ -1,4 +1,5 @@
 #
+# Copyright (C) 2010-2011 OpenWrt.org
 # Copyright (C) 2010 Gianluigi Tiesi <sherpya@netfarm.it>
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=axel
 PKG_VERSION:=2.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://alioth.debian.org/frs/download.php/3015
@@ -22,6 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/axel
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=File Transfer
   TITLE:=Axel Download Accelerator
   DEPENDS:=+libpthread
   URL:=http://axel.alioth.debian.org/
@@ -35,13 +37,13 @@ define Package/axel/description
 endef
 
 # notes:
-#  - I'm using = and not += because it is not a standard configure script
+#  - I'm using := and not += because it is not a standard configure script
 #  - I ask not to strip, because it should be handled by the toolchain
-CONFIGURE_ARGS =       \
-       --prefix=/usr   \
-       --etcdir=/etc   \
-       --debug=0               \
-       --i18n=0                \
+CONFIGURE_ARGS := \
+       --prefix=/usr \
+       --etcdir=/etc \
+       --debug=0 \
+       --i18n=0 \
        --strip=0
 
 define Package/axel/install
@@ -52,4 +54,8 @@ define Package/axel/install
        echo "alternate_output = 1" >> $(1)/etc/axelrc
 endef
 
+define Package/axel/conffiles
+/etc/axelrc
+endef
+
 $(eval $(call BuildPackage,axel))