global: change all instances of USE_EGLIBC to USE_GLIBC
[packages.git] / net / atftp / Makefile
index e09e452..2190f88 100644 (file)
@@ -1,75 +1,70 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=atftp
 PKG_VERSION:=0.7
-PKG_RELEASE:=1
-PKG_MD5SUM:=3b27365772d918050b2251d98a9c7c82
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=ftp://ftp.mamalinux.com/pub/atftp/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-TAR_OPTIONS += || true
+PKG_SOURCE_URL:=http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/distfiles/
+PKG_MD5SUM:=3b27365772d918050b2251d98a9c7c82
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=libncurses libpcre libreadline
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/atftp
+define Package/atftp/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libreadline +libpcre
-  MENU:=1
-  TITLE:=TFTP client
-  DESCRIPTION:=TFTP client
-  URL:=ftp://ftp.mamalinux.com/pub/atftp/
+  TITLE:=TFTP
+  SUBMENU:=File Transfer
 endef
 
-define Package/atftpd
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=atftp +libreadline +libpcre
-  TITLE:=TFTP server
-  DESCRIPTION:=TFTP server
-  URL:=ftp://ftp.mamalinux.com/pub/atftp/
+define Package/atftp
+  $(call Package/atftp/Default)
+  DEPENDS:=+libreadline +libncurses
+  TITLE+= client
 endef
 
-define Package/atftpd/postinst
-#!/bin/sh
-grep -q '^tftp[[:space:]]*69/tcp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-if [ $$? -ne 0 ]; then
-       echo "tftp            69/tcp" >>$${IPKG_INSTROOT}/etc/services
-       echo "tftp            69/udp" >>$${IPKG_INSTROOT}/etc/services
-       echo "tftp-mcast    1758/tcp" >>$${IPKG_INSTROOT}/etc/services
-       echo "tftp-mcast    1758/udp" >>$${IPKG_INSTROOT}/etc/services
-fi
+define Package/atftpd
+  $(call Package/atftp/Default)
+  DEPENDS:=+libpcre +libpthread
+  TITLE+= server
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -Wall -D_REENTRANT" \
-               DESTDIR=$(PKG_INSTALL_DIR) \
-               all install
-endef
+CONFIGURE_ARGS += \
+       --disable-libwrap
+CONFIGURE_VARS += \
+       LDFLAGS="$(TARGET_LDFLAGS) $(TARGET_CFLAGS)"
+
+ifdef CONFIG_USE_GLIBC
+  TARGET_CFLAGS += -DHAVE_ARGZ=1
+
+  define Build/Prepare
+       $(Build/Prepare/Default)
+       echo '#include_next <argz.h>' > $(PKG_BUILD_DIR)/argz.h
+  endef
+endif
+
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) -Wall -D_REENTRANT" \
+       all
 
 define Package/atftp/install
-       install -m0755 -d $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/atftp $(1)/usr/sbin/
 endef
 
 define Package/atftpd/install
-       install -m0755 -d $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/atftpd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,atftp))