kismet: moved to github
[packages.git] / net / apcupsd / Makefile
index 65e3500..8816a7a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apcupsd
-PKG_VERSION:=3.14.2
-PKG_RELEASE:=1
+PKG_VERSION:=3.14.7
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/apcupsd
-PKG_MD5SUM:=fd8785e7607d20cefa68dc20e44eebc4
-PKG_CAT:=zcat
+PKG_MD5SUM:=bb2f8e4fc6b2f5d7b3e236eb57b81640
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/apcupsd
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libpthread
+  DEPENDS:=+libpthread +libusb-compat
   TITLE:=UPS control software
   URL:=http://www.apcupsd.org/
 endef
@@ -31,6 +30,8 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --with-distname=unknown \
                --sysconfdir=/etc/apcupsd \
+               --enable-usb \
+               --without-x \
        )
 endef
 
@@ -60,4 +61,14 @@ define Package/apcupsd/install
        $(INSTALL_BIN)  ./files/apcupsd.init $(1)/etc/init.d/apcupsd
 endef
 
+define Package/apcupsd/conffiles
+/etc/apcupsd/apcupsd.conf
+/etc/apcupsd/apcupsd_mail.conf
+/etc/apcupsd/changeme
+/etc/apcupsd/commfailure
+/etc/apcupsd/commok
+/etc/apcupsd/offbattery
+/etc/apcupsd/onbattery
+endef
+
 $(eval $(call BuildPackage,apcupsd))