shaiport: disable pulseaudio backend
[packages.git] / multimedia / crtmpserver / Makefile
index 046eeb6..64e8f5a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2010 OpenWrt.org
+#
+# Copyright (C) 2010-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=crtmpserver
 PKG_REV:=726
 PKG_VERSION:=r$(PKG_REV)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=--username=anonymous --password= https://svn.rtmpd.com/crtmpserver/trunk
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/crtmpserver
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libopenssl +libstdcpp
+  DEPENDS:=+libopenssl +libstdcpp +liblua
   TITLE:=C++ RTMP Server
   URL:=http://www.rtmpd.com/
 endef
@@ -35,7 +35,7 @@ stream (live or recorded) in the following technologies:
  * To and from embedded devices: iPhone, Android
  * From surveillance cameras
  * IP-TV using MPEG-TS and RTSP/RTCP/RTP protocols
-                
+
 Also, crtmpserver can be used as a high performance rendes-vous
 server. For example, it enables you to do:
  * Audio/Video conferencing
@@ -61,7 +61,8 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/builders/make \
+       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/builders/make \
+               CFLAGS="$(TARGET_CFLAGS)" \
                PLATFORM=linux-openwrt-uclibc
 endef
 
@@ -82,4 +83,3 @@ define Package/crtmpserver/install
 endef
 
 $(eval $(call BuildPackage,crtmpserver))
-