libipfix: fix build
[packages.git] / libs / openldap / Makefile
index 49c2dc9..5344080 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openldap
-PKG_VERSION:=2.4.19
+PKG_VERSION:=2.4.39
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
@@ -16,28 +16,33 @@ PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
        ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/ \
        ftp://ftp.nl.uu.net/pub/unix/db/openldap/openldap-release/ \
        ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
-PKG_MD5SUM:=4a6dab2711fcf141f19bb680bc335887
+PKG_MD5SUM:=b0d5ee4b252c841dec6b332d679cf943
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/openldap/Default
   TITLE:=LDAP implementation
   URL:=http://www.openldap.org/
+  MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+endef
+
+define Package/openldap/Default/description
+       OpenLDAP Software is an open source implementation of the
+       Lightweight Directory Access Protocol (LDAP).
 endef
 
 define Package/libopenldap
   $(call Package/openldap/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libopenssl +libsasl2
+  DEPENDS:=+libopenssl +libsasl2 +libpthread
   TITLE+= (libraries)
 endef
 
 define Package/libopenldap/description
-       OpenLDAP Software is an open source implementation of the 
-       Lightweight Directory Access Protocol (LDAP).   
+       $(call Package/openldap/Default/description)
        This package contains the shared LDAP client libraries, needed by other programs.
 endef
 
@@ -54,8 +59,7 @@ define Package/openldap-utils
 endef
 
 define Package/openldap-utils/description
-       OpenLDAP Software is an open source implementation of the 
-       Lightweight Directory Access Protocol (LDAP).   
+       $(call Package/openldap/Default/description)
        This package contains client programs required to access LDAP servers.
 endef
 
@@ -63,17 +67,20 @@ define Package/openldap-server
   $(call Package/openldap/Default)
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenldap +db47
+  DEPENDS:=+libopenldap +libuuid
   TITLE+= (server)
 endef
 
 define Package/openldap-server/description
-       OpenLDAP Software is an open source implementation of the 
-       Lightweight Directory Access Protocol (LDAP).   
+       $(call Package/openldap/Default/description)
        This package contains server programs required to provide LDAP services.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+define Package/openldap-server/conffiles
+/etc/openldap/slapd.conf
+endef
+
+TARGET_CFLAGS += $(FPIC) -lpthread
 
 CONFIGURE_ARGS += \
        --enable-shared \
@@ -90,8 +97,12 @@ CONFIGURE_ARGS += \
        --with-yielding_select="yes" \
        --without-cyrus-sasl \
        --without-threads \
-       --without-tls 
-
+       --without-tls \
+       --enable-null \
+       --disable-bdb \
+       --disable-hdb \
+       --disable-monitor \
+       --disable-relay
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -101,32 +112,37 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libopenldap/install
        $(INSTALL_DIR) $(1)/etc/openldap
-       $(CP) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
 endef
-       
+
 define Package/openldap-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ldap* $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ldap* $(1)/usr/bin/
 endef
-       
+
 define Package/openldap-server/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ldap.init $(1)/etc/init.d/ldap
        $(INSTALL_DIR) $(1)/etc/openldap/schema
-       $(CP) $(PKG_INSTALL_DIR)/etc/openldap/schema/* $(1)/etc/openldap/schema/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/schema/* $(1)/etc/openldap/schema/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/slapd.conf $(1)/etc/openldap/
        $(INSTALL_DIR) $(1)/usr/sbin
-       # OpenLDAP installs slapd into libexecdir, not sbindir:
+       # XXX: OpenLDAP installs slapd into libexecdir, not sbindir:
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/slapd $(1)/usr/sbin/
+       # XXX: switch default backend to ldif, since bdb is disabled
+       $(SED) 's|^\(database\)\([ \t]\+\)bdb|\1\2ldif|g' \
+           -e 's|^\(index\)|#\1|g' \
+           $(1)/etc/openldap/slapd.conf
 endef
 
 $(eval $(call BuildPackage,libopenldap))