unixodbc: moved to github
[packages.git] / libs / libxslt / Makefile
index 9e9645e..c78c540 100644 (file)
@@ -1,26 +1,25 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libxslt
-PKG_VERSION:=1.1.24
+PKG_VERSION:=1.1.28
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
        ftp://fr.rpmfind.net/pub/libxml/
-PKG_MD5SUM:=e83ec5d27fc4c10c6f612879bea9a153
-PKG_FIXUP:=libtool
+PKG_MD5SUM:=9667bf6f9310b957254fdcf6596600b7
 
-include $(INCLUDE_DIR)/package.mk
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
-PKG_INSTALL=1
+include $(INCLUDE_DIR)/package.mk
 
 define Package/libxslt
   SECTION:=libs
@@ -34,10 +33,22 @@ define Package/libxslt/description
        A library for XML transformation using XSLT.
 endef
 
+define Package/libexslt
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libxslt
+  TITLE:=Gnome XSLT library Extention
+  URL:=http://xmlsoft.org/XSLT/EXSLT/
+endef
+
+define Package/libexslt/description
+       A extention for XSLT.
+endef
+
 define Package/xsltproc
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libxml2 +libxslt
+  DEPENDS:=+libxml2 +libxslt +libexslt
   TITLE:=Gnome XSLT xsltproc Utility
   URL:=http://xmlsoft.org/XSLT/
 endef
@@ -46,22 +57,20 @@ define Package/xsltproc/description
        XSLT XML transformation utility
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --without-python \
-               --without-crypto \
-               --without-debug \
-               --without-mem-debug \
-               --without-debugger \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --without-python \
+       --without-crypto \
+       --without-debug \
+       --without-mem-debug \
+       --without-debugger \
 
 TARGET_CFLAGS += $(FPIC)
 
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt $(1)/usr/lib \
+define Build/InstallDev/Xslt
+       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt \
+               $(1)/usr/include/libexslt $(1)/usr/lib \
                $(1)/usr/lib/pkgconfig $(2)/share/aclocal
 
        $(INSTALL_BIN) \
@@ -78,8 +87,8 @@ define Build/InstallDev
                $(PKG_INSTALL_DIR)/usr/include/libxslt/* \
                $(1)/usr/include/libxslt/
 
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/lib/libxslt.{la,so*} \
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libxslt.{la,a,so*} \
                $(1)/usr/lib/
 
        $(INSTALL_DATA) \
@@ -91,13 +100,40 @@ define Build/InstallDev
                $(2)/share/aclocal
 endef
 
+define Build/InstallDev/Exslt
+       $(INSTALL_DIR) $(1)/usr/include/libexslt $(1)/usr/lib/pkgconfig
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/libexslt/* \
+               $(1)/usr/include/libexslt/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libexslt.{la,a,so*} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libexslt.pc \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+define Build/InstallDev
+        $(if $(CONFIG_PACKAGE_libxslt),$(call Build/InstallDev/Xslt,$(1),$(2)))
+        $(if $(CONFIG_PACKAGE_libexslt),$(call Build/InstallDev/Exslt,$(1),$(2)))
+endef
+
 define Package/libxslt/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/libxslt.so.* \
                $(1)/usr/lib/
 endef
 
+define Package/libexslt/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libexslt.so.* \
+               $(1)/usr/lib/
+endef
+
 define Package/xsltproc/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
@@ -106,4 +142,5 @@ define Package/xsltproc/install
 endef
 
 $(eval $(call BuildPackage,libxslt))
+$(eval $(call BuildPackage,libexslt))
 $(eval $(call BuildPackage,xsltproc))