[packages] libtorrent: update to 0.13.3-git
[packages.git] / libs / libtorrent / patches / 100-fix_cross_compile.patch
index 8f0fbb9..202ee00 100644 (file)
@@ -1,28 +1,41 @@
-Index: libtorrent-0.12.6_r1209/configure.ac
-===================================================================
---- libtorrent-0.12.6_r1209.orig/configure.ac  2011-03-27 12:23:16.000000000 +0200
-+++ libtorrent-0.12.6_r1209/configure.ac       2011-04-13 16:33:17.487339738 +0200
-@@ -17,7 +17,6 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -19,7 +19,6 @@ AC_SUBST(LIBTORRENT_INTERFACE_VERSION_NO
  
  AM_INIT_AUTOMAKE
- AM_CONFIG_HEADER(config.h)
+ AC_CONFIG_HEADERS(config.h)
 -AM_PATH_CPPUNIT(1.9.6)
- AC_DISABLE_STATIC
  
- AM_DISABLE_STATIC
-@@ -118,5 +117,4 @@
-       src/protocol/Makefile
-       src/tracker/Makefile
-       src/utils/Makefile
--        test/Makefile
- ])
-Index: libtorrent-0.12.6_r1209/Makefile.am
-===================================================================
---- libtorrent-0.12.6_r1209.orig/Makefile.am   2010-03-01 20:04:58.000000000 +0100
-+++ libtorrent-0.12.6_r1209/Makefile.am        2011-04-13 16:33:17.487339738 +0200
-@@ -1,4 +1,4 @@
--SUBDIRS = src test
-+SUBDIRS = src
+ AC_PROG_CXX
  
- pkgconfigdir = $(libdir)/pkgconfig
- pkgconfig_DATA = libtorrent.pc
+--- a/scripts/checks.m4
++++ b/scripts/checks.m4
+@@ -96,7 +96,7 @@ AC_DEFUN([TORRENT_CHECK_KQUEUE], [
+ AC_DEFUN([TORRENT_CHECK_KQUEUE_SOCKET_ONLY], [
+   AC_MSG_CHECKING(whether kqueue supports pipes and ptys)
+-  AC_RUN_IFELSE([AC_LANG_SOURCE([
++  AC_LINK_IFELSE([AC_LANG_SOURCE([
+       #include <fcntl.h>
+       #include <stdlib.h>
+       #include <unistd.h>
+--- a/scripts/common.m4
++++ b/scripts/common.m4
+@@ -223,7 +223,7 @@ dnl   Need to fix this so that it uses t
+ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
+   AC_MSG_CHECKING(for execinfo.h)
+-  AC_RUN_IFELSE([AC_LANG_SOURCE([
++  AC_LINK_IFELSE([AC_LANG_SOURCE([
+       #include <execinfo.h>
+       int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
+       ])],
+@@ -238,7 +238,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
+ AC_DEFUN([TORRENT_CHECK_ALIGNED], [
+   AC_MSG_CHECKING(the byte alignment)
+-  AC_RUN_IFELSE([AC_LANG_SOURCE([
++  AC_LINK_IFELSE([AC_LANG_SOURCE([
+       #include <inttypes.h>
+       int main() {
+         char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 };