[packages] libtorrent: update to 0.13.3-git
[packages.git] / libs / libtorrent / patches / 100-fix_cross_compile.patch
index 7030718..202ee00 100644 (file)
@@ -1,31 +1,41 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -19,7 +19,6 @@ AC_SUBST(LIBTORRENT_INTERFACE_VERSION_NO
+ AM_INIT_AUTOMAKE
+ AC_CONFIG_HEADERS(config.h)
+-AM_PATH_CPPUNIT(1.9.6)
+ AC_PROG_CXX
 --- a/scripts/checks.m4
 +++ b/scripts/checks.m4
 @@ -96,7 +96,7 @@ AC_DEFUN([TORRENT_CHECK_KQUEUE], [
  AC_DEFUN([TORRENT_CHECK_KQUEUE_SOCKET_ONLY], [
    AC_MSG_CHECKING(whether kqueue supports pipes and ptys)
  
--  AC_RUN_IFELSE(
-+  AC_LINK_IFELSE(
-     [[#include <fcntl.h>
+-  AC_RUN_IFELSE([AC_LANG_SOURCE([
++  AC_LINK_IFELSE([AC_LANG_SOURCE([
+       #include <fcntl.h>
        #include <stdlib.h>
        #include <unistd.h>
 --- a/scripts/common.m4
 +++ b/scripts/common.m4
-@@ -184,7 +184,7 @@ AC_DEFUN([TORRENT_CHECK_MADVISE], [
+@@ -223,7 +223,7 @@ dnl   Need to fix this so that it uses t
  AC_DEFUN([TORRENT_CHECK_EXECINFO], [
    AC_MSG_CHECKING(for execinfo.h)
  
--  AC_RUN_IFELSE(
-+  AC_LINK_IFELSE(
-     [[#include <execinfo.h>
+-  AC_RUN_IFELSE([AC_LANG_SOURCE([
++  AC_LINK_IFELSE([AC_LANG_SOURCE([
+       #include <execinfo.h>
        int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
-     ]],
-@@ -199,7 +199,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
+       ])],
+@@ -238,7 +238,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
  AC_DEFUN([TORRENT_CHECK_ALIGNED], [
    AC_MSG_CHECKING(the byte alignment)
  
--  AC_RUN_IFELSE(
-+  AC_LINK_IFELSE(
-     [[#include <inttypes.h>
+-  AC_RUN_IFELSE([AC_LANG_SOURCE([
++  AC_LINK_IFELSE([AC_LANG_SOURCE([
+       #include <inttypes.h>
        int main() {
-         char buf[8] = { 0, 0, 0, 0, 1, 0, 0, 0 };
+         char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 };