[packages] massive: use $(INSTALL_DIR) instead of 'mkdir -p' in install and InstallDev
[packages.git] / libs / libid3tag / Makefile
index d21ef5f..ba1ad20 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -31,6 +30,8 @@ define Package/libid3tag/description
        ID3v1 and the various versions of ID3v2.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -47,9 +48,9 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/id3tag.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libid3tag.{a,so*} $(1)/usr/lib/
 endef