postgresql: moved to github
[packages.git] / libs / libgssapi / Makefile
index 02fed6f..01de32d 100644 (file)
@@ -1,38 +1,43 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgssapi
 PKG_VERSION:=0.11
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.citi.umich.edu/projects/nfsv4/linux/libgssapi/
 PKG_MD5SUM:=0e5b4c7267724f8ddf64bc35514c272e
 
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libgssapi
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=required libraries for the nfs-utils
-  DESCRIPTION:= Support libraries - for newer nfs mount command (nfs4)
   URL:=http://www.citi.umich.edu/projects/nfsv4/linux
 endef
 
-TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
+define Package/libgssapi/description
+ Support libraries - for newer nfs mount command (nfs4)
+endef
+
+TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib $(FPIC)
 
 MAKE_FLAGS += \
        OPT="$(TARGET_CFLAGS)" \
        INSTALLSUID="install -m 4755" \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
+       DESTDIR="$(PKG_INSTALL_DIR)"
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/gssglue/gssapi
@@ -43,11 +48,4 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libgssapi.pc $(1)/usr/lib/pkgconfig
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/gssglue \
-               $(STAGING_DIR)/usr/lib/libgssapi.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/libgssapi.pc
-endef
-
 $(eval $(call BuildPackage,libgssapi))