[packages] clean fixups
[packages.git] / libs / avahi / Makefile
index 89c5513..647166a 100644 (file)
@@ -1,26 +1,27 @@
 #
-
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.6.21
+PKG_VERSION:=0.6.28
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://avahi.org/download/
-PKG_MD5SUM:=9cc68f79c50c9dd9e419990c3c9b05b9
+PKG_MD5SUM:=d0143a5aa3265019072e53ab497818d0
+
+PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm intltool/host
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_REMOVE_FILES:=autogen.sh
 
-PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,23 +32,28 @@ define Package/avahi/Default
   URL:=http://www.avahi.org/
 endef
 
+define Package/avahi/Default/description
+ An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
+ Avahi is a system which facilitates service discovery on a local network --
+ this means that you can plug your laptop or computer into a network and
+ instantly be able to view other people who you can chat with, find printers
+ to print to or find files being shared. This kind of technology is already
+ found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf')
+ and is very convenient.
+endef
+
 define Package/libavahi
   $(call Package/avahi/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libdaemon +libpthread
+  DEPENDS:=+libdaemon +libpthread +libgdbm
   TITLE+= (library)
 endef
 
 define Package/libavahi/description
-       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
-       Avahi is a system which facilitates service discovery on a local network --
-       this means that you can plug your laptop or computer into a network and
-       instantly be able to view other people who you can chat with, find printers
-       to print to or find files being shared. This kind of technology is already
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf')
-       and is very convenient.
-       This package contains the mDNS/DNS-SD shared libraries, used by other programs.
+$(call Package/avahi/Default/description)
+ .
+ This package contains the mDNS/DNS-SD shared libraries, used by other programs.
 endef
 
 define Package/avahi-autoipd
@@ -57,19 +63,13 @@ define Package/avahi-autoipd
 endef
 
 define Package/avahi-autoipd/description
-       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
-       Avahi is a system which facilitates service discovery on a local network --
-       this means that you can plug your laptop or computer into a network and
-       instantly be able to view other people who you can chat with, find printers
-       to print to or find files being shared. This kind of technology is already
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf')
-       and is very convenient.
-       This package implements IPv4LL, "Dynamic Configuration of
-       IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for
-       automatic IP address configuration from the link-local
-       169.254.0.0/16 range without the need for a central server. It
-       is primarily intended to be used in ad-hoc networks which lack a
-       DHCP server.
+$(call Package/avahi/Default/description)
+ .
+ This package implements IPv4LL, "Dynamic Configuration of IPv4 Link-Local 
+ Addresses" (IETF RFC3927), a protocol for automatic IP address configuration 
+ from the link-local 169.254.0.0/16 range without the need for a central 
+ server. It is primarily intended to be used in ad-hoc networks which lack a
+ DHCP server.
 endef
 
 define Package/avahi-daemon
@@ -79,14 +79,9 @@ define Package/avahi-daemon
 endef
 
 define Package/avahi-daemon/description
-       An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
-       Avahi is a system which facilitates service discovery on a local network --
-       this means that you can plug your laptop or computer into a network and
-       instantly be able to view other people who you can chat with, find printers
-       to print to or find files being shared. This kind of technology is already
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf')
-       and is very convenient.
-       This package contains an mDNS/DNS-SD daemon.
+$(call Package/avahi/Default/description)
+ .
+ This package contains an mDNS/DNS-SD daemon.
 endef
 
 define Package/avahi-daemon/conffiles
@@ -102,60 +97,65 @@ define Package/avahi-dnsconfd
 endef
 
 define Package/avahi-dnsconfd/description
-       This package contains an Unicast DNS server from mDNS/DNS-SD configuration
-       daemon, which may be used to configure conventional DNS servers using mDNS
-       in a DHCP-like fashion. Especially useful on IPv6.
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-glib \
-               --disable-qt3 \
-               --disable-qt4 \
-               --disable-gtk \
-               --disable-dbus \
-               --enable-expat \
-               --disable-dbm \
-               --enable-gdbm \
-               --enable-libdaemon \
-               --disable-python \
-               --disable-pygtk \
-               --disable-python-dbus \
-               --disable-mono \
-               --disable-monodoc \
-               --disable-doxygen-doc \
-               --disable-doxygen-dot \
-               --disable-doxygen-man \
-               --disable-doxygen-rtf \
-               --disable-doxygen-xml \
-               --disable-doxygen-chm \
-               --disable-doxygen-chi \
-               --disable-doxygen-html \
-               --disable-doxygen-ps \
-               --disable-doxygen-pdf \
-               --disable-xmltoman \
-               --with-distro=none \
-               --with-avahi-user=nobody \
-               --with-avahi-group=nogroup \
-               , \
-               CFLAGS="$$$$CFLAGS -DNDEBUG" \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+$(call Package/avahi/Default/description)
+ .
+ This package contains an Unicast DNS server from mDNS/DNS-SD configuration
+ daemon, which may be used to configure conventional DNS servers using mDNS
+ in a DHCP-like fashion. Especially useful on IPv6.
+endef
+
+TARGET_CFLAGS += $(FPIC) -DGETTEXT_PACKAGE
+
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --disable-glib \
+       --disable-gobject \
+       --disable-qt3 \
+       --disable-qt4 \
+       --disable-gtk \
+       --disable-gtk3 \
+       --disable-dbus \
+       --with-xml=expat \
+       --disable-dbm \
+       --enable-gdbm \
+       --enable-libdaemon \
+       --disable-python \
+       --disable-pygtk \
+       --disable-python-dbus \
+       --disable-mono \
+       --disable-monodoc \
+       --disable-doxygen-doc \
+       --disable-doxygen-dot \
+       --disable-doxygen-man \
+       --disable-doxygen-rtf \
+       --disable-doxygen-xml \
+       --disable-doxygen-chm \
+       --disable-doxygen-chi \
+       --disable-doxygen-html \
+       --disable-doxygen-ps \
+       --disable-doxygen-pdf \
+       --disable-xmltoman \
+       --with-distro=none \
+       --with-avahi-user=nobody \
+       --with-avahi-group=nogroup \
+       --with-autoipd-user=nobody \
+       --with-autoipd-group=nogroup
+
+ifneq ($(CONFIG_SSP_SUPPORT),y)
+CONFIGURE_ARGS+= \
+       --disable-stack-protector
+endif
+
+CONFIGURE_VARS+= \
+       CFLAGS="$$$$CFLAGS -DNDEBUG -DDISABLE_SYSTEMD" \
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/avahi-{common,core} $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-{common,core}.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/avahi-core.pc $(1)/usr/lib/pkgconfig/
 endef