[packages] remove/cleanup another round of fixups
[packages.git] / libs / apr / Makefile
index a9394dc..5445c9b 100644 (file)
@@ -1,22 +1,24 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$ 
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apr
-PKG_VERSION:=1.2.9
+PKG_VERSION:=1.4.2
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://apache.d-s-s-p.de/apr/
-PKG_MD5SUM:=6f4b063ac01a54ba0818c31280f06959
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.ibiblio.org/pub/mirrors/apache/apr
+PKG_MD5SUM:=4b00e8f70c067893d075577962656b35
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_REMOVE_FILES:=build/libtool.m4
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,23 +30,20 @@ define Package/libapr
   URL:=http://apr.apache.org/
 endef
 
+TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += \
        --with-devrandom=/dev/urandom \
        --disable-dso \
        --enable-ipv6
 
+# XXX: ac_cv_sizeof_struct_iovec=1 is just to trick configure
 CONFIGURE_VARS += \
-       ac_cv_file__dev_zero=yes \
+       ac_cv_sizeof_struct_iovec=1 \
        apr_cv_process_shared_works=no \
        apr_cv_mutex_robust_shared=no \
        apr_cv_tcp_nodelay_with_cork=yes \
-       ac_cv_sizeof_ssize_t=4 \
        LDFLAGS="$$$$LDFLAGS -lpthread" \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1 $(1)/usr/lib $(1)/usr/lib/pkgconfig $(1)/usr/share/build-1
        $(CP)   $(PKG_INSTALL_DIR)/usr/bin/apr-1-config \