python: refresh patches
[packages.git] / lang / python / patches / 070-dont-clean-ipkg-install.patch
index 0eb04bb..0eee56b 100644 (file)
@@ -1,8 +1,12 @@
---- Python-2.5.1/Makefile.pre.in.orig  2008-10-02 12:30:28.000000000 +0200
-+++ Python-2.5.1/Makefile.pre.in       2008-10-02 12:31:50.000000000 +0200
-@@ -996,11 +996,11 @@
+---
+ Makefile.pre.in |    6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- Python-2.6.4.orig/Makefile.pre.in
++++ Python-2.6.4/Makefile.pre.in
+@@ -1118,11 +1118,11 @@ TAGS::
  # Sanitation targets -- clean leaves libraries, executables and tags
- # files, which clobber removes those as well
+ # files, which clobber removes as well
  pycremoval:
 -      find $(srcdir) -name '*.py[co]' -exec rm -f {} ';'
 +      find $(srcdir) ! -path './ipkg-install/*' -name '*.py[co]' -exec rm -f {} ';'
@@ -14,4 +18,4 @@
 +      find . ! -path './ipkg-install/*' -name '*.s[ol]' -exec rm -f {} ';'
        find $(srcdir)/build -name 'fficonfig.h' -exec rm -f {} ';' || true
        find $(srcdir)/build -name 'fficonfig.py' -exec rm -f {} ';' || true
+       -rm -f Lib/lib2to3/*Grammar*.pickle