Update python to 2.6.1.
[packages.git] / lang / python / patches / 000-cross-compile.patch
index f89d3e3..4cbab18 100644 (file)
@@ -2,7 +2,7 @@ Index: Python-2.5.1/Makefile.pre.in
 ===================================================================
 --- Python-2.5.1.orig/Makefile.pre.in  2007-07-30 12:55:24.000000000 -0500
 +++ Python-2.5.1/Makefile.pre.in       2007-07-30 12:55:24.000000000 -0500
-@@ -170,6 +170,7 @@
+@@ -175,6 +175,7 @@
  
  PYTHON=               python$(EXE)
  BUILDPYTHON=  python$(BUILDEXE)
@@ -10,7 +10,7 @@ Index: Python-2.5.1/Makefile.pre.in
  
  # === Definitions added by makesetup ===
  
-@@ -196,7 +197,7 @@
+@@ -205,7 +206,7 @@
  ##########################################################################
  # Parser
  PGEN=         Parser/pgen$(EXE)
@@ -19,27 +19,28 @@ Index: Python-2.5.1/Makefile.pre.in
  POBJS=                \
                Parser/acceler.o \
                Parser/grammar1.o \
-@@ -345,8 +346,8 @@
+@@ -394,8 +395,8 @@
  # Build the shared modules
  sharedmods: $(BUILDPYTHON)
-       case $$MAKEFLAGS in \
--      *-s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py -q build;; \
+       @case $$MAKEFLAGS in \
+-      *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py -q build;; \
 -      *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
-+      *-s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py -q build;; \
++      *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py -q build;; \
 +      *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py build;; \
-       esac
+       esac
  
  # Build static library
-@@ -470,7 +471,7 @@
+@@ -512,8 +513,8 @@
  
  
  $(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
+               -@$(INSTALL) -d Include
 -              -$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
 +              -$(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
  
  $(PGEN):      $(PGENOBJS)
                $(CC) $(OPT) $(LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
-@@ -885,7 +886,7 @@
+@@ -993,7 +994,7 @@
  # Install the dynamically loadable modules
  # This goes into $(exec_prefix)
  sharedinstall:
@@ -48,37 +49,70 @@ Index: Python-2.5.1/Makefile.pre.in
                --prefix=$(prefix) \
                --install-scripts=$(BINDIR) \
                --install-platlib=$(DESTSHARED) \
-Index: Python-2.5.1/setup.py
-===================================================================
---- Python-2.5.1.orig/setup.py 2007-07-30 12:55:24.000000000 -0500
-+++ Python-2.5.1/setup.py      2007-07-30 12:57:10.000000000 -0500
-@@ -209,6 +209,7 @@
-         try:
-             imp.load_dynamic(ext.name, ext_filename)
-         except ImportError, why:
-+            return
-             self.announce('*** WARNING: renaming "%s" since importing it'
-                           ' failed: %s' % (ext.name, why), level=3)
-             assert not self.inplace
-@@ -244,8 +245,6 @@
-     def detect_modules(self):
-         # Ensure that /usr/local is always used
--        add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
--        add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
-         # Add paths specified in the environment variables LDFLAGS and
-         # CPPFLAGS for header and library files.
-@@ -279,12 +278,6 @@
-                     for directory in options.dirs:
-                         add_dir_to_list(dir_list, directory)
--        if os.path.normpath(sys.prefix) != '/usr':
--            add_dir_to_list(self.compiler.library_dirs,
--                            sysconfig.get_config_var("LIBDIR"))
--            add_dir_to_list(self.compiler.include_dirs,
--                            sysconfig.get_config_var("INCLUDEDIR"))
--
-         try:
-             have_unicode = unicode
-         except NameError:
+diff --git a/Makefile.pre.in b/Makefile.pre.in
+index c2ce5c6..63dc91e 100644
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -371,7 +371,7 @@ build_all_generate_profile:
+       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
+ run_profile_task:
+-      ./$(BUILDPYTHON) $(PROFILE_TASK)
++      $(HOSTPYTHON) $(PROFILE_TASK)
+ build_all_use_profile:
+       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-use"
+@@ -389,7 +389,7 @@ $(BUILDPYTHON):    Modules/python.o $(LIBRARY) $(LDLIBRARY)
+                       $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
+ platform: $(BUILDPYTHON)
+-      $(RUNSHARED) ./$(BUILDPYTHON) -E -c 'import sys ; from distutils.util import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
++      $(RUNSHARED) $(HOSTPYTHON) -E -c 'import sys ; from distutils.util import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
+ # Build the shared modules
+@@ -669,7 +669,7 @@ $(LIBRARY_OBJS) $(MODOBJS) Modules/python.o: $(PYTHON_HEADERS)
+ TESTOPTS=     -l $(EXTRATESTOPTS)
+ TESTPROG=     $(srcdir)/Lib/test/regrtest.py
+-TESTPYTHON=   $(RUNSHARED) ./$(BUILDPYTHON) -E -tt
++TESTPYTHON=   $(RUNSHARED) $(HOSTPYTHON) -E -tt
+ test:         all platform
+               -find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
+@@ -1032,7 +1014,7 @@ frameworkinstallstructure:       $(LDLIBRARY)
+               fi; \
+       done
+       $(LN) -fsn include/python$(VERSION) $(DESTDIR)$(prefix)/Headers
+-      sed 's/%VERSION%/'"`$(RUNSHARED) ./$(BUILDPYTHON) -c 'import platform; print platform.python_version()'`"'/g' < $(RESSRCDIR)/Info.plist > $(DESTDIR)$(prefix)/Resources/Info.plist
++      sed 's/%VERSION%/'"`$(RUNSHARED) $(HOSTPYTHON) -c 'import platform; print platform.python_version()'`"'/g' < $(RESSRCDIR)/Info.plist > $(DESTDIR)$(prefix)/Resources/Info.plist
+       $(LN) -fsn $(VERSION) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Versions/Current
+       $(LN) -fsn Versions/Current/$(PYTHONFRAMEWORK) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/$(PYTHONFRAMEWORK)
+       $(LN) -fsn Versions/Current/Headers $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Headers
+@@ -1074,7 +1056,7 @@ frameworkinstallextras:
+ # This installs a few of the useful scripts in Tools/scripts
+ scriptsinstall:
+       SRCDIR=$(srcdir) $(RUNSHARED) \
+-      ./$(BUILDPYTHON) $(srcdir)/Tools/scripts/setup.py install \
++      $(HOSTPYTHON) $(srcdir)/Tools/scripts/setup.py install \
+       --prefix=$(prefix) \
+       --install-scripts=$(BINDIR) \
+       --root=/$(DESTDIR)
+@@ -1096,7 +1078,7 @@ config.status:   $(srcdir)/configure
+ # Run reindent on the library
+ reindent:
+-      ./$(BUILDPYTHON) $(srcdir)/Tools/scripts/reindent.py -r $(srcdir)/Lib
++      $(HOSTPYTHON) $(srcdir)/Tools/scripts/reindent.py -r $(srcdir)/Lib
+ # Rerun configure with the same options as it was run last time,
+ # provided the config.status script exists
+@@ -1192,7 +1174,7 @@ funny:
+ # Perform some verification checks on any modified files.
+ patchcheck:
+-      $(RUNSHARED) ./$(BUILDPYTHON) $(srcdir)/Tools/scripts/patchcheck.py
++      $(RUNSHARED) $(HOSTPYTHON) $(srcdir)/Tools/scripts/patchcheck.py
+ # Dependencies