[packages] jamvm: Bump release number, update copyright date
[packages.git] / lang / pymysql / Makefile
index 2375f6f..9a54f26 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,20 +14,19 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mysql-python
 PKG_MD5SUM:=532268f02870bea18c1d465e88afff30
+
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
+$(call include_mk, python-package.mk)
 
 define Package/python-mysql
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=MySQL database adapter for Python
   URL:=http://mysql-python.sourceforge.net/
-  DEPENDS:=python-core +libmysqlclient
+  DEPENDS:=+python +libmysqlclient
 endef
 
 define Package/python-mysql/description
@@ -43,6 +41,7 @@ define PyPackage/python-mysql/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )