clean up python packaging code.
[packages.git] / lang / pymysql / Makefile
index 177c239..868643b 100644 (file)
@@ -15,22 +15,28 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mysql-python
 PKG_MD5SUM:=532268f02870bea18c1d465e88afff30
+PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
-include ../python/python-package.mk
-
-define PyPackage/pymysql
- TITLE:=MySQL database adapter for Python
- URL=http://mysql-python.sourceforge.net/
- DEPENDS+= +libmysqlclient
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+ifeq ($(DUMP)$(Build/Compile/PyMod),)
+  $(error Python packaging code not found.)
+endif
+
+define Package/python-mysql
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=MySQL database adapter for Python
+  URL:=http://mysql-python.sourceforge.net/
+  DEPENDS:=python-core +libmysqlclient
 endef
 
-define PyPackage/pymysql/description
+define Package/python-mysql/description
  MySQLdb is an thread-compatible interface to the popular MySQL database 
  server that provides the Python database API.
 endef
 
-define PyPackage/pymysql/filespec
+define PyPackage/python-mysql/filespec
 +|$(PYTHON_PKG_DIR)/_mysql.so
 +|$(PYTHON_PKG_DIR)/_mysql_exceptions.py*
 +|$(PYTHON_PKG_DIR)/MySQLdb
@@ -42,4 +48,5 @@ define Build/Compile
        )
 endef
 
-$(eval $(call PyPackage,pymysql))
+$(eval $(call PyPackage,python-mysql))
+$(eval $(call BuildPackage,python-mysql))