remove libusb-legacy and point its users at libusb-compat
[packages.git] / lang / luaexpat / Makefile
index f0f424e..ded0229 100644 (file)
@@ -4,27 +4,26 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luaexpat
 PKG_VERSION:=1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://luaforge.net/frs/download.php/2469
+PKG_SOURCE_URL:=http://luaforge.net/frs/download.php/2469
 PKG_MD5SUM:=6ecb895ccf5cff1e7f2facd438b1f8d0
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/luaexpat
-  SUBMENU:=LUA
+  SUBMENU:=Lua
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=LUAexpat 
+  TITLE:=LuaExpat 
   URL:=http://www.keplerproject.org/luaexpat/
-  DEPENDS:=lua +libexpat
+  DEPENDS:=+lua +libexpat
 endef
 
 define Package/luaexpat/description
@@ -41,8 +40,8 @@ define Build/Compile
        LUA_INC="$(STAGING_DIR)/usr/include/" \
        LUA_LIBDIR="$(STAGING_DIR)/usr/lib/" \
        COMPAT_DIR="$(PKG_BUILD_DIR)/compat-5.1r5" \
-       LIB_OPTION="-shared -L$(STAGING_DIR)/usr/lib/" \
-       CC="$(TARGET_CC) $(TARGET_CFLAGS)" \
+       LIB_OPTION="-shared $(TARGET_LDFLAGS)" \
+       CC="$(TARGET_CC) $(TARGET_CFLAGS) $(FPIC) -std=c99" \
        LD="$(TARGET_CROSS)ld -shared" 
 endef