packages/egenix-mx: fix whitespaces
[packages.git] / lang / jamvm / Makefile
index 1209f1a..a56d29e 100644 (file)
@@ -1,58 +1,69 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=jamvm
-PKG_VERSION:=1.4.4
-PKG_RELEASE:=1
+PKG_VERSION:=1.6.0-git
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/jamvm
-PKG_MD5SUM:=1b7bc9928c534412e062685a4191651d
-PKG_CAT:=zcat
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.berlios.de/jamvm
+PKG_SOURCE_VERSION:=4617da717ecb05654ea5bb9572338061106a414d
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_MIRROR_MD5SUM:=66a728a3cb8dad0e3773035c4049eb5f
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_USE_MIPS16:=0
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/jamvm
+  SUBMENU:=Java
   SECTION:=lang
   CATEGORY:=Languages
-  DEPENDS:=+libffi-sable
   TITLE:=A compact Java Virtual Machine
-  DESCRIPTION:=\
-       JamVM is a new Java Virtual Machine which conforms to the JVM \\\
-       specification version (blue book). In comparison to most other VM's \\\
-       (free and commercial) it is extremely small.However, unlike other \\\
-       small VMs (e.g. KVM) it is designed to support the full \\\
-       specification, and includes support for object finalisation, \\\
-       Soft/Weak/Phantom References, the Java Native Interface (JNI) and the \\\
-       Reflection API.
   URL:=http://sourceforge.net/projects/jamvm
+  DEPENDS:=+zlib +libpthread +librt +classpath @!avr32
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-ffi \
-               --disable-int-threading \
-       )
+define Package/jamvm/description
+ JamVM is a new Java Virtual Machine which conforms to the JVM 
+ specification version (blue book). In comparison to most other VM's (free 
+ and commercial) it is extremely small.However, unlike other small VMs 
+ (e.g. KVM) it is designed to support the full specification, and includes 
+ support for object finalisation, Soft/Weak/Phantom References, the Java 
+ Native Interface (JNI) and the Reflection API.
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) all
+CONFIGURE_ARGS += \
+       --with-java-runtime-library=gnuclasspath \
+       --with-classpath-install-dir=/usr \
+       --disable-int-inlining \
+       --disable-shared \
+       --without-pic
+
+MAKE_FLAGS += \
+       GLIBJ_ZIP=$(STAGING_DIR)/usr/share/classpath/glibj.zip
+
+define Package/jamvm/install
+       $(INSTALL_DIR) $(1)/usr
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/bin \
+               $(PKG_INSTALL_DIR)/usr/share \
+               $(1)/usr/
 endef
 
-define Package/jamvm/install   
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/jamvm $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/usr/share/jamvm
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/lib/classes.zip $(1)/usr/share/jamvm/
+define Build/InstallDev
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
 $(eval $(call BuildPackage,jamvm))
+